hosted engine tests failing on Cannot detect virualization

Description

http://jenkins.ovirt.org/job/ovirt-system-tests_he-basic-suite-master/20/artifact/exported-artifacts/test_logs/he-basic-suite-master/post-002_bootstrap.py/lago-he-basic-suite-master-host0/_var_log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20170904230243-cxf8oc.log/*view*/

2017-09-04 23:02:43,880-0400 DEBUG otopi.ovirt_host_deploy.hardware
hardware.getVendor:52 cpuinfo:
2017-09-04 23:02:43,880-0400 DEBUG otopi.ovirt_host_deploy.hardware
hardware.detect:210 Cannot detect virualization
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/ovirt_host_deploy/hardware.py",
line 199, in detect
if self._isVirtualizationEnabled():
File "/usr/lib/python2.7/site-packages/ovirt_host_deploy/hardware.py",
line 175, in _isVirtualizationEnabled
bios_ok = self._vmx_enabled_by_bios()
File "/usr/lib/python2.7/site-packages/ovirt_host_deploy/hardware.py",
line 134, in _vmx_enabled_by_bios
self._prdmsr(0, MSR_IA32_FEATURE_CONTROL) & (
File "/usr/lib/python2.7/site-packages/ovirt_host_deploy/hardware.py",
line 121, in _prdmsr
ret = struct.unpack('L', f.read(8))[0]
IOError: [Errno 5] Input/output error
2017-09-04 23:02:43,881-0400 WARNING
otopi.plugins.gr_he_setup.vdsmd.cpu cpu._setup:153 Cannot detect if
hardware supports virtualization

Anything changed on host configuration / lago that prevent virtualization
being detected?

SANDRO BONAZZOLA

ASSOCIATE MANAGER, SOFTWARE ENGINEERING, EMEA ENG VIRTUALIZATION R&D

Red Hat EMEA <https://www.redhat.com/>
<https://red.ht/sig>
TRIED. TESTED. TRUSTED. <https://redhat.com/trusted>

Status

Assignee

Evgheni Dereveanchin

Reporter

Sandro Bonazzola

Blocked By

None

Priority

Medium