broken on FC27 because of GDBM import issues


Unit tests for '' Python code have shown us that it now fails with errors while importing the 'gdbm' package.

It seems the latest 'gdbm' package in Fedora (1.14-1) was changes in a way that is incompatible with its Python bindings. The previous version (1.13-3) seems to work just fine.

A bug was reported to the Fedora project:


Barak Korren
January 30, 2018, 10:08 AM

given that 'gdbm-1.14-1.fc27.x86_64' is in our repos - won't 'dnf update' pull it, there by breaking the slave?

Evgheni Dereveanchin
January 30, 2018, 10:22 AM

Patch submitted to use the latest mirror snapshot that has gdbm-1.13-6.fc27

I applied a full OS update from this snapshot manually on vm0177 - need to check if this doesn't bring any other incompatible packages before merging. is there a test job I could run on this node? How would I do this? I'd also need to document this process as part of

Evgheni Dereveanchin
January 30, 2018, 1:03 PM

regarding 0.14-1 being present in the repos - looks like this is worked around by using epoch versions: I tried updating a slave with 0.13-3 and it got 0.13-6 instead of 0.14-1

Daniel Belenky
January 31, 2018, 12:04 PM

I think that it's enough to update the mirror config and ensure that it's indeed the correct gdbm version.
Otherwise, if you insist on a strict testing, you could send another patch to Jenkins repo that changes any python code in the Jenkins repo (this will trigger python unit tests) and base this new patch on top of the patch that changes the mirror config.

Evgheni Dereveanchin
January 31, 2018, 1:14 PM

Patch merged. If any regressions surface due to package version in this snapshot, let's open a new ticket. Closing this one.


Evgheni Dereveanchin


Barak Korren

Blocked By

Waituing on response for bug