https://resources.ovirt.org/pub/ovirt-master-snapshot/iso/ is corrupted

Description

https://resources.ovirt.org/pub/ovirt-master-snapshot/iso/ has a broken tree
.
├── ovirt-node-ng-installer-HEAD
├── ovirt-node-ng-installer-master
├── ovirt-node-ng-installer-master----
│ └── 020204
├── ovirt-node-ng-installer-master-----
│ └── 20204
├── ovirt-node-ng-installer-master------
│ └── 3104
├── ovirt-node-ng-installer-master-------
│ └── 104
├── ovirt-node-ng-installer-master--------
│ └── 04
├── ovirt-node-ng-installer-master---------
│ ├── 4
│ └── 9
├── ovirt-node-ng-nightly-boot
└── oVirt-toolsSetup
└── 4.2-0_master.20170126155024.git44a8701.fc24

looks like the publishing job is either not publishing isos or not working
correctly.

SANDRO BONAZZOLA

MANAGER, SOFTWARE ENGINEERING, EMEA R&D RHV

Red Hat EMEA <https://www.redhat.com/>

sbonazzo@redhat.com
<https://red.ht/sig>

Activity

Show:
Ehud Yonasi
February 6, 2019, 1:29 PM

it is currently doing it exactly, last dir for iso is distro.
for the publisher matter i am currently looking into it (i suspect it's our internals scripts inside resources that do not publish iso's)

Eyal Edri
February 6, 2019, 10:52 AM

Its being published to tested, so the copy to snapshot job should be checked to make sure it copies ISO from tested:
https://resources.ovirt.org/repos/ovirt/tested/master/iso/ovirt-node-ng-installer/.

The regex should probably change as well to make it $distro/isoname.iso, instead of
https://resources.ovirt.org/repos/ovirt/tested/master/iso/ovirt-node-ng-installer/4.3.0-2019020609/el7/

Sandro Bonazzola
February 5, 2019, 10:41 AM

ok, now it's clean.
Question is: why ISO are not being published there? But we probably need to track this in a different issue.

Ehud Yonasi
February 4, 2019, 4:11 PM

I deleted the masters and HEAD

Sandro Bonazzola
February 4, 2019, 4:00 PM

yes, you can delete empty directories

Fixed
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Ehud Yonasi

Reporter

Sandro Bonazzola