poll-upstream-sources pipelines don't work on el8 nodes

Description

Trying to run `poll-upstream-sources` pipeline on an el8 node ends with an error:

After an attempt of resolving the issue by installing python2 and setting the unversioned python command to point to python2 we fail on dependencies:

A quick look at the `usrc.py` script shows we need at least 3 deps:

  • python2-six

  • python2-pyyaml

  • python2-pyxdg (or simply pyxdg)
    The last package is not available at all in el8 repos.

Please provide a solution to this problem by either moving the script to use py3 or any other means.

Assignee

infra

Reporter

Marcin Sobczyk

Blocked By

None

Priority

Medium
Configure