Problem with Jenkins ovirt-ansible-collection

Description

Hi,

for some reason the Jenkins does not start a job for
ovirt-ansible-collection, few days ago it worked without a problem, could
someone please check it out/redirect me to someone?

Martin Necas

Activity

Show:
Krapali Rai
December 7, 2020, 3:25 PM

Hi

It looks like the webhook is working fine now. So we are closing this ticket. Also, we are reviewing the other webhooks in below ticket:

https://projects.engineering.redhat.com/browse/RHEVINTEG-3424

Please let me know if you encounter any issue related to this.

Krapali

Krapali Rai
December 1, 2020, 4:48 AM

Hi ,

It seems the webhooks are in place now. Please confirm if you are still facing any issues or if it is working fine.

Thanks for identifying and fixing the issue. As suggested by you, we can continue reviewing webhooks for other repos in a separate ticket.

Thanks,

Krapali

Evgheni Dereveanchin
November 27, 2020, 12:23 AM
Edited

I replaced the old user/pass credential with ID ovirt-infra with the one named github-auth-token - it seems to be for the same user in fact.

 

Issuing a comment to did start a build so hopefully we’re back on track now: https://jenkins.ovirt.org/job/oVirt_ovirt-ansible-collection_standard-check-pr/448/

 

We still need to verify if we have other tools or Jenkins instances using this deprecated method.

Evgheni Dereveanchin
November 27, 2020, 12:08 AM

I was finally able to look through Jenkins logs and I think I see our issue:

 

Caused: org.kohsuke.github.HttpException: {"message":"Bad credentials. The API can't be accessed using username/password authentication. Please create a personal access token to access this endpoint: http://github.com/settings/tokens","documentation_url":"https://docs.github.com/articles/creating-a-personal-access-token-for-the-command-line"}

 

The plugin is still configured to use password auth which has been deprecated for a long time and I thought we removed it from Jenkins already.

 

Basically this errors out when checking if the user is a member of the organization, assumes that not and never even starts a job.

Anton Marchukov
November 25, 2020, 12:37 PM
Edited

So far we were able to check the following:

  1. It is related to events that are handled by GitHub Pull Requests Builder plugin [1]. This explains why only comments and PR items are not triggered (they are routed through this plugin) and merges (pushes) uses different one that works.

  2. From GitHub project setting looks like the webhooks were sent by GitHub properly. Also the webhooks are there (but since the old ones are not deleted it is not clear if plugin still able to create them on jenkins start or not).

  3. From jenkins side the job is not triggered at least it does not get to executing Groovy code at least in visible way.

  4. “Failed to detect stage from trigger event or parameters” in the Jenkins log is not a reason, this happens when Jenkins job is started manually using “Build Now”. This won’t work and give this error. And it was done for this particular job hence those errors.

We will continue investigation. To me it currently looks like some possible problem with the plugin (that is abandoned and up to adoption). But it is still not clear and confirmed what the actual problem exactly is.

[1] https://plugins.jenkins.io/ghprb/

Fixed
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Krapali Rai

Reporter

Martin Necas