CI OST: hardware acceleration not available, kvm executable not found

Description

Hi all,

Recent runs fail with $subject, e.g.:

https://jenkins.ovirt.org/job/ovirt-system-tests_standard-check-patch/14269/console

08:40:07 Package
qemu-kvm-15:4.2.0-34.module_el8.3.0+555+a55c8938.x86_64 is already
installed.

08:45:03 hardware acceleration not available
08:45:03 emulator not found b'<capabilities>\n\n <host>\n
<uuid>4c4c4544-0038-4410-8039-b7c04f333832</uuid>\n <cpu>\n
<arch>x86_64</arch>\n <model>Haswell-noTSX-IBRS</model>\n
<vendor>Intel</vendor>\n <microcode version="67"/>\n
<counter name="tsc" frequency="2397222000" scaling="no"/>\n
<topology sockets="1" dies="1" cores="8" threads="2"/>\n <feature
name="vme"/>\n <feature name="ds"/>\n <feature
name="acpi"/>\n <feature name="ss"/>\n <feature
name="ht"/>\n <feature name="tm"/>\n <feature name="pbe"/>\n
<feature name="dtes64"/>\n <feature name="monitor"/>\n
<feature name="ds_cpl"/>\n <feature name="vmx"/>\n <feature
name="smx"/>\n <feature name="est"/>\n <feature
name="tm2"/>\n <feature name="xtpr"/>\n <feature
name="pdcm"/>\n <feature name="dca"/>\n <feature
name="osxsave"/>\n <feature name="f16c"/>\n <feature
name="rdrand"/>\n <feature name="arat"/>\n <feature
name="tsc_adjust"/>\n <feature name="cmt"/>\n <feature
name="md-clear"/>\n <feature name="stibp"/>\n <feature
name="ssbd"/>\n <feature name="xsaveopt"/>\n <feature
name="pdpe1gb"/>\n <feature name="abm"/>\n <feature
name="invtsc"/>\n <pages unit="KiB" size="4"/>\n <pages
unit="KiB" size="2048"/>\n <pages unit="KiB" size="1048576"/>\n
</cpu>\n <power_management>\n <suspend_mem/>\n
<suspend_disk/>\n <suspend_hybrid/>\n </power_management>\n
<iommu support="no"/>\n <migration_features>\n <live/>\n
<uri_transports>\n <uri_transport>tcp</uri_transport>\n
<uri_transport>rdma</uri_transport>\n </uri_transports>\n
</migration_features>\n <topology>\n <cells num="1">\n
<cell id="0">\n <memory unit="KiB">115148964</memory>\n
<pages unit="KiB" size="4">28787241</pages>\n <pages
unit="KiB" size="2048">0</pages>\n <pages unit="KiB"
size="1048576">0</pages>\n <distances>\n <sibling
id="0" value="10"/>\n </distances>\n <cpus
num="16">\n <cpu id="0" socket_id="0" die_id="0"
core_id="0" siblings="0,8"/>\n <cpu id="1" socket_id="0"
die_id="0" core_id="1" siblings="1,9"/>\n <cpu id="2"
socket_id="0" die_id="0" core_id="2" siblings="2,10"/>\n
<cpu id="3" socket_id="0" die_id="0" core_id="3" siblings="3,11"/>\n
<cpu id="4" socket_id="0" die_id="0" core_id="4"
siblings="4,12"/>\n <cpu id="5" socket_id="0" die_id="0"
core_id="5" siblings="5,13"/>\n <cpu id="6" socket_id="0"
die_id="0" core_id="6" siblings="6,14"/>\n <cpu id="7"
socket_id="0" die_id="0" core_id="7" siblings="7,15"/>\n
<cpu id="8" socket_id="0" die_id="0" core_id="0" siblings="0,8"/>\n
<cpu id="9" socket_id="0" die_id="0" core_id="1"
siblings="1,9"/>\n <cpu id="10" socket_id="0" die_id="0"
core_id="2" siblings="2,10"/>\n <cpu id="11" socket_id="0"
die_id="0" core_id="3" siblings="3,11"/>\n <cpu id="12"
socket_id="0" die_id="0" core_id="4" siblings="4,12"/>\n
<cpu id="13" socket_id="0" die_id="0" core_id="5" siblings="5,13"/>\n
<cpu id="14" socket_id="0" die_id="0" core_id="6"
siblings="6,14"/>\n <cpu id="15" socket_id="0" die_id="0"
core_id="7" siblings="7,15"/>\n </cpus>\n </cell>\n
</cells>\n </topology>\n <cache>\n <bank id="0" level="3"
type="both" size="20" unit="MiB" cpus="0-15"/>\n </cache>\n
<secmodel>\n <model>selinux</model>\n <doi>0</doi>\n
<baselabel type="kvm">system_u:system_r:svirt_t:s0</baselabel>\n
<baselabel type="qemu">system_u:system_r:svirt_tcg_t:s0</baselabel>\n
</secmodel>\n <secmodel>\n <model>dac</model>\n
<doi>0</doi>\n <baselabel type="kvm">+107:+107</baselabel>\n
<baselabel type="qemu">+107:+107</baselabel>\n </secmodel>\n
</host>\n\n</capabilities>'

As you can see, above does not include any '<guest>' sections.
Searching for relevant keywords I can find:

https://bugzilla.redhat.com/show_bug.cgi?id=1066630

So perhaps some dependency of qemu is not installed, or not updated?

Thanks and best regards,

Didi

Activity

Show:
Ehud Yonasi
December 8, 2020, 1:03 PM

Hey Didi,

We are trying to build the ost-images for centos 8.3.

Galit Rosenthal
December 8, 2020, 9:32 AM

HI,

This issue is being handled.
Once it will be solved will let you know

Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Ehud Yonasi

Reporter

Yedidyah Bar David