ci-tools repo does not support RHEL7

Description

The ci-tools repo does not work with RHEL7.

Our puppet manifests set it up the following way:
baseurl=http://resources.ovirt.org/repos/ci-tools/EL/$releasever

On RHEL7 this results in:
http://resources.ovirt.org/repos/ci-tools/EL/7Server/
which does not exist.

Can we create a symlink 7Server -> 7 to make it work? It looks like a similar config ins in place for RHEL6.

The current ci-tools puppet manifest is here:
https://gerrit.ovirt.org/gitweb?p=infra-puppet.git;a=blob;f=site/ovirt_base/manifests/ci_tools_repo.pp;h=1d36c79f4dc891ee71ceecf05ed733a0f85ef613;hb=refs/heads/production

Activity

Show:
Barak Korren
August 8, 2016, 4:47 PM

We can just create a symlink on resources.ovirt.org.
Not sure if we have some script somewhere to generate it.

Evgheni Dereveanchin
August 9, 2016, 12:32 PM

Barak, thanks for the comment.

I went to the resources server and as expected, 6Server was a symlink to 6:

ls -l /srv/resources/repos/ci-tools/EL/
total 0
lrwxrwxrwx. 1 root root 6 Jun 3 2014 6 -> ../el6
lrwxrwxrwx. 1 root root 6 May 30 07:13 6Server -> ../el6
lrwxrwxrwx. 1 root root 6 Jun 23 2014 7 -> ../el7

So I just made a new symlink

ls -l /srv/resources/repos/ci-tools/EL/
total 0
lrwxrwxrwx. 1 root root 6 Jun 3 2014 6 -> ../el6
lrwxrwxrwx. 1 root root 6 May 30 07:13 6Server -> ../el6
lrwxrwxrwx. 1 root root 6 Jun 23 2014 7 -> ../el7
lrwxrwxrwx. 1 root root 6 Aug 9 12:28 7Server -> ../el7

The repo works fine on RHEL7 now.

Evgheni Dereveanchin
August 15, 2016, 7:19 AM

closing since the error is gone with the new symlink

Fixed

Assignee

infra

Reporter

Evgheni Dereveanchin

Blocked By

None

Epic Link

Components

Priority

Medium