Cannot create a new project in Gerrit

Description

Trying to follow the instructions to create a new project here:
http://ovirt-infra-docs.readthedocs.io/en/latest/General/Creating_Gerrit_Projects.html

Yields the following error in the web UI regardless of the name entered:

Code Review - Error
400 invalid project name: foobar

Trying to do the same from the CLI with the following command:

Also yields an error:

So far I haven't found anything in the logs to indicate why is this happening.

Activity

Show:
Marc Dequènes (Duck)
August 17, 2016, 1:44 PM

I see nothing in history or Puppet rules explaining these wrong (altered at some point in time) permissions.

Eyal Edri
August 17, 2016, 1:52 PM

The problem with Gerrit is that its not managed by puppet, so all changes
are done locally (for e.g the hooks for the projects that are under git dir.

We need to puppetize it soon and move all hooks and gerrit conf to
git/puppet in order to track all changes.
There is already a ticket opened on it, we'll need to prioritize it seeing
how critical gerrit is and how often we need to update hooks.

On Wed, Aug 17, 2016 at 4:45 PM, Marc Dequènes (Duck) (oVirt JIRA) <


Eyal Edri
Associate Manager
RHV DevOps
EMEA ENG Virtualization R&D
Red Hat Israel

phone: +972-9-7692018
irc: eedri (on #tlv #rhev-dev #rhev-integ)

Barak Korren
August 17, 2016, 1:52 PM

Ok, with the local file permission change, adding a repo now worked.

Barak Korren
August 17, 2016, 1:54 PM

File permissions fixed by (Thanks!) on Gerrit server.

Gil Shinar
July 16, 2017, 12:40 PM

The folder has got its owner back to be root.
Tried to find the entity that changes it with no success. Tried cron jobs, init script and hooks.

Fixed

Assignee

infra

Reporter

Barak Korren

Blocked By

None

Components

Priority

High
Configure